Batarang出事了

一直以来,Batarang作为调试Angularjs应用的神器备受好评。不过,也有不少人说Angular官方对其更新得太慢,还不如第三方的ng-inspector好用。平心而论,ng-inspector确实查看Scope很方便,而Batarang除Scope查看分析功能外,还有另外两大功能:jsHint和性能检测。可以说两者不是一个级别的扩展程序。

不过最近官方将其更新到0.10.6,不少开发人员反映Batarang升级后不能在他们的电脑上使用了。本来是“顺民意”的一件好事,却招致不少开发者的谩骂。你说该不该骂?其实Angularjs batarang升级后还能用的,但只是对基于AngularJS 1.2x及以上版本开发的应用起作用,AngularJS 1.5版本可用但会报TypeError,希望Angular团队尽早修复这个Bug。

我觉得Angular团队应该解释一下这个问题,可能他们花更多精力去开发Angularjs 2了。

注意:使用Batarang如果失效,请检查AngularJS版本请并按Ctrl + Shift + R硬性重新加载当前页面。

发表评论